[TYPO3-core] PHP version requirement

Ernesto Baschny ernesto.baschny at typo3.org
Fri Mar 8 16:36:29 CET 2013

Karsten Dambekalns schrieb am 08.03.2013 15:53:

> On 08.03.2013, at 10:07, Ernesto Baschny <ernesto.baschny at typo3.org> wrote:
>> Karsten said he is "looking forward tp the day I can drop those
>> workarounds". Well, sorry to tell you: the solutions you are building
>> now based on "latest stable" PHP 5.3 (or even 5.4) will probably look
>> awkward as soon as we have new possibilities in PHP 5.5 or later in a
>> couple of years.
> Using new stuff and replacing awkward things by something better is not an issue. In fact, that is fun.
> What I mean is code like this, which is "added for the past" only:
>  https://review.typo3.org/#/c/18556/7/Classes/TYPO3/Flow/Utility/TypeHandling.php

Or course it is fun to replace it, but you see that there always will be
the need to include such awkward code.

> For me that is a huge difference. :)

As long as Flow doesn't have any strict release life-cycles, guaranteed
support time, a "LTS" version, or a strict backwards compatibility
policy etc, you can of course do whatever you want. You could even tell
people "just use Flow 2.0 because we won't care for Flow 1.1 anymore in
a couple of months". This is fine, you never promised anything about it.
Or did you?

According to [1] even Flow 2.0 seems to support PHP 5.3.2. Why? This is
not consistent to what you are saying. Maybe you are not representing
the "Flow Release Team" with your opinion? Or maybe you haven't even
discussed the matter in the Flow team yet? There is no clue in the
release notes to the minimum required PHP version.

As soon as you enter a phase where people need to trust that the
framework will be supported for more than a couple of months (but
*years* instead), you cannot just go with "cutting edge" PHP versions
anymore. The Flow contributors will need to learn how to deal with that
and you will have to create some policies and make certain commitments.
Which sometimes mean to support a 3-4 year old PHP version!

See for example Symfony 2 plans [2]. Do you think Symfony 2.2.0 which
just came out requires PHP 5.3.3 because it is fun?

We are in this situation in TYPO3 CMS for years now, and you cannot deny
that we need to stick to some kind of maintenance policy, else we will
loose (even more) quickly the user base, support from agencies and
businesses. This has nothing to do with personal likings or even that
"enterprise means something outstanding", it's just a matter that people
(even small businesses needing a stupid tiny website) TRUST that we care
about it. And I would love to keep it that way!

This is why I (and Stucki) think it is very important that at least our
fellow TYPO3 CMS Core Developers keeps this in their spirit while
working on TYPO3: focus on stability, backwards compatibility, and have
a strict eye on PHP compatibility. We also need to consider that this is
not something "evil" but something people expect from us and can be
equally satisfying than getting rid of some awkward code snippet.

Best regards,

[1] http://flow.typo3.org/download.html
[2] http://symfony.com/doc/current/contributing/community/releases.html

Ernesto Baschny
Core Developer V4 Team
Release Manager TYPO3 4.5

TYPO3 .... inspiring people to share!
Get involved: typo3.org

More information about the TYPO3-team-core mailing list