[TYPO3-core] RFC: #7333: Solution for "Page is being generated"

Michael Stucki michael at typo3.org
Tue Feb 5 16:04:36 CET 2008


Hi Ingo,

> ok, fine. just as with Bernhard's patch:
> please split lockPageGenerate() into lockPageGeneration() and
> releasePageGeneration() or aquirePageGenerationLock() and
> releasePageGenerationLock()

Alright, changed.

> * init -> __construct()

I disagree! First, the constructor would not allow any parameters. Second,
it is not possible to reinitialize an existing object otherwise.

> * no $OK variables - what precisely is ok?

I agree that this is sometimes confusing, but in this case it appears pretty
clear to me, isn't it? Well, I can rename it to $success if you like that
more...

> * $is_acquired -> $isAcquired (also does not need initialization during
> definition as you initialize it in the constructor)

The idea was that the lockObject can be reused by calling init() again.

> * when detecting the locking method just throw an exception if it's not
> in the set of possible values and then maybe surround the
> aquirePageGenerationLock() with a try-catch statement

done

> * acquire and release (private) methods should be split into several
> methods instead of having large switches -> aquireSimple, aquireFlock,
> aquireSemaphore, releaseSimple, ...

Later. I also thought about using separate classes for each method. This
would make it easily extendable...

> * function getid() -> getId()

done

> * provide public function isAquired() : boolean

done

New patch is attached.

> +1 after reading

Thank you. However, since the feature is pretty experimental and requires a
lot of more testing, I thought about turning it off by default. What do you
think?

I want to avoid that beta1 is considered a failure because some yet
uncovered problem with this feature...

- michael
-- 
Use a newsreader! Check out
http://typo3.org/community/mailing-lists/use-a-news-reader/
-------------- next part --------------
A non-text attachment was scrubbed...
Name: lockPageGeneration_v2.diff
Type: text/x-diff
Size: 16263 bytes
Desc: not available
Url : http://lists.netfielders.de/pipermail/typo3-team-core/attachments/20080205/6c9d0467/attachment.diff 


More information about the TYPO3-team-core mailing list