[TYPO3-core] RFC: a hook in TCEforms to complement hook in TCEmain

Martin Kutschker Martin.Kutschker at n0spam-blackbox.net
Thu Aug 30 16:25:34 CEST 2007

Dmitry Dulepov [typo3] schrieb:
>> OTOH, I'd like to see 'eval' to be deprecated in favour of the new 
>> properties 'required', 'inputTransformation' (FORM->DB), 
>> 'outputTransformation' (DB->FORM), 'validation' and maybe 
>> 'inputValidation'.
> Yes but this will complicate forms in extensions. Currently developers 
> just say "I want it to be integer from 10 to 100" and it is there.

Why? Now you fill in 'eval' then you would fill in 'validation'. Why is 
this more complex?

> May be evaluations should not be built-in but provided as separate 
> classes. This way we need not to have hooks, they all will be loaded 
> dynamically and any field can be altered if necessary.

I haven't thought about the extensability right now, but of course it 
shouldn't be a fixed set.

> And, as you pointed, we should have validation as separate thing. 
> Currently "date" is really evaluation

I would call it 'inputTransformation'. In case of the date you have to set 
it up both for input and output, but eg md5 is an input-only transformation.


More information about the TYPO3-team-core mailing list