[TYPO3-templavoila] FCE and availibility of fields (10.file.width.field = field_width)

Dmitry Dulepov dmitry.dulepov at gmail.com
Fri Nov 7 21:05:27 CET 2008


Niels Fröhling wrote:
> What would you suggest? I think "tx_templavoila_pi1.parentRec." is not
> so wrong (semantically).

Earlier I suggested to use another register.

> How about naming it after the real DB-field
> "tx_templavoila_pi1.parentRec.tx_templavoila_flex.", which would put it
> exactly besides the other DB-fields?

This looks good too. It can be come very complex though:
and it will not work with sections unless syntax becomes even more

To me this functionality looks like coming from "we do it because we
can". I do not see having it as a big advantage. I can be mistaken,
of course :) I am not God to know all use cases :)

> The __SERIAL approach is IMHO a huge waste of resources in comparison to
> the otherwise low-complextiy of the pi1. It would also significanty
> simplify the code of processDataValues, which helps for the
> implementation of the slide.

We can neither remove, nor change behaviour of any existing
registers. This should be remembered. Otherwise we can optimize code
as necessary :)

Dmitry Dulepov
TYPO3 translations support
My TYPO3 book: http://www.packtpub.com/typo3-extension-development/book
In the blog:

More information about the TYPO3-project-templavoila mailing list