[TYPO3-templavoila] FCE and availibility of fields (10.file.width.field = field_width)

Niels Fröhling niels.froehling at adsignum.com
Fri Nov 7 14:21:16 CET 2008


Dmitry Dulepov wrote:
> Hi!
>
> Niels Fröhling wrote:
>   
>> It's the one existing way how you can spread the TV-data deeper into the
>> TS-tree:
>>     
>
> parentObj is reserved to access parent object. If you have a patch
> to allow accessing flexform fields on different levels, do not use
> parentObj there. Use another register name.
>
>   
What would you suggest? I think "tx_templavoila_pi1.parentRec." is not
so wrong (semantically).
How about naming it after the real DB-field
"tx_templavoila_pi1.parentRec.tx_templavoila_flex.", which would put it
exactly besides the other DB-fields?

BTW: I didn't do it yet but I suggest to move the whole in-loop __SERIAL
register-setup/checking/removing of processDataValues into
renderElement. I sat some time thinking about the taken approach and
it's unnesesary if processDataValues would be private (no external
calls). And even if it should exist as API-entry I suggest to rearrange
it this way:

renderElement() {
  set registers
  processDataValuesInternal (recursion)
  unset registers
}

processDataValues() {
  set registers
  processDataValuesInternal (recursion)
  unset registers
}

processDataValuesInternal (recursion) {
  processDataValuesInternal (recursion)
}

The __SERIAL approach is IMHO a huge waste of resources in comparison to
the otherwise low-complextiy of the pi1. It would also significanty
simplify the code of processDataValues, which helps for the
implementation of the slide.

Ciao
    Niels





More information about the TYPO3-project-templavoila mailing list