[TYPO3-english] fresh install

Mark Smith typo3org at awayand.sleepmail.com
Sat Jan 23 19:53:10 CET 2010

On Fri, 22 Jan 2010 08:50 +0000, "Denyerec" <denyerec at gmail.com> wrote:
> On Fri, 22 Jan 2010 01:10:38 -0000, Mark Smith  
> <typo3org at awayand.sleepmail.com> wrote:
> > Trying to access the database with these credentials using a normal
> > mysql client works fine. Any ideas on how to troubleshoot this?
> I'd start by looking at the PHP and MySQL logs to see if any error output 
> is generated by your attempt to log in. Did you test the credentials on  
> the same host the website is located? It could be that the hostname isn't 
> correct for the TYPO3 installation?

I think I have nailed it down. I am launching mysqld with the following
command line just for debugging, of course (I enabled php errors output
and increase verbosity, but php doesn't complain about anything):

[root at ks php]# mysqld --verbose --user=root --general-log
--log-output=file --general-log-file /var/log/mysqld.log

Then I go to:
and try to put in user: root, password: secret, host: localhost

I still get error: The current username, password or host was not
accepted when the connection to the database was attempted to be

Looking at my mysqld-log, I have this: 100123 19:45:52     7 Connect  
Access denied for user 'http'@'localhost' (using password: NO)

How about that? http is obviously the username apache is running as.
Note, no matter what I put in, I can put in an IP for the host, or DNS
alias for the host, or even put in a different username or any username,
it will give me the same error. It looks like the install script is
stuck with trying to login as http without supplying a password.

Is there something I am missing?

I am using archlinux kernel, apache 2.2.14-2,
mysql 5.1.42-1, php 5.3.1-3


More information about the TYPO3-english mailing list