[TYPO3-english] cli_dispatch.phpsh does not respond with --AUTOFIX (SOLVED)

Søren Madsen sma at cs.au.dk
Mon Jun 15 15:14:50 CEST 2009

> I'm trying to clean up our base installation, and was intending to use
> the tools provided in cli_dispatch.phpsh
> The tests run fin - eg. if I run 'php typo3/cli_dispatch.phpsh
> lowlevel_cleaner missing_files -s -r' I get a list of referenced files
> that no longer exist.
> However - if I run the same command with the --AUTOFIX option, the
> script does not respond - I have tried to let it run for about 45
> minuttes, but nothing happens - not even a time out or anything.
> The same goes for the other tools, such as orphan_records, deleted,
> etc. - they respond fine with just the -r flag, but nothing happens
> when I execute them with --AUTOFIX.
> Does anyone know what could be going wrong here? Thx in advance!

Figured it out. We traced that the script was running, but was waiting  
for input. For some reason (perhaps something with our buffer/  
memory ?), the script did not output the following dialogue:

NOW Running --AUTOFIX on result. OK? (Yes/No + return):

So simply typing Yes in the empty waiting new line, triggered the  
script to proceed.

Kind regards,
Søren Madsen

More information about the TYPO3-english mailing list