[TYPO3-english] mailform and powermail not sending mails

Celso Reeks typo3 at distopia.com
Sat Jun 13 06:09:00 CEST 2009


I'm having some trouble creating contact forms on my Typo3 setup.

Whenever I create a form for sending mail, whether it is using Typo3's  
buil-in mailform or using extension Powermail, the forms render  
perfectly on the page, but clicking the submit button either sends me  
to the homepage or back to the same page I was on, with the addition  
of all the form values appended to the URL.  No mail is sent.  It  
seems like something is disabled, because I have also tried not  
filling required inputs and I still get the same behaviors.  No errors  
appear on the screen or in the logs.   Quite strange...

I have also done the test on the Install script.  Mailing there is  
working fine.

Does anybody know a fix? First I thought it could be a problem on my  
host (dreamhost.com), but I checked another Typo3 installation and  
everything seems fine.  Or could it be something with the version I am  
using?  The mail problem is happening on a Typo3 4.2.6 install, while  
the successful mailing is on a Typo3 4.0.1 install.

It seems to me that the forms are not able to send/process the data  

This is my current configuration:

Typo3: 4.2.6
PHP: 5.2.6
Powermail: 1.4.15

Best regards,
Celso Reeks

More information about the TYPO3-english mailing list