[TYPO3] Solved - Re: image magick 5.5.6 & t3 4.0.1

Katja Lampela katja.lampela at lieska.net
Fri Sep 1 10:05:02 CEST 2006

The versions work just fine together - there was a misconfiguration in 
the install tool. I suppose it had happen somewhere in the upgradin, 
though I can't remember actually changing anything there.

Anyway the wrong-doing was in the Install tool/All configuration/GFX:
String. Set this if you're using ImageMagick/GraphicsMagick but not IM 
4.x. Setting this value will automatically configure some settings for 
use with the specified program version. Allowed values are: "im4", 
"im5", "im6" and "gm" (uses GraphicsMagick instead of ImageMagick).

I tried here values "im5" and "im6". The right value is "1".


Katja Lampela wrote:
> Hi,
> I've got t3 4.0.1 and Image magick 5.5.6 04/01/03 Q16.
> Problem: the pictures seem to render mainly ok but some just don't. I 
> can't find any logic in what formats are okay and what aren't but the 
> pictures so far have all been gifs that don't show - but again, some 
> gifs do show alright.
> Install tool's Basic configuration says "No ImageMagick install 
> available" but it is there in /usr/bin/. And my host provider says it's 
> a basic installation.
> Current Install tool Image processing says (I've tried also different 
> configurations though):
> ImageMagick enabled: 1
> ImageMagick path: /usr/bin/ ()
> ImageMagick path/LZW: /usr/bin/ ()
> Version 5/GraphicsMagick flag: im5
> GDLib enabled: 1
> GDLib using PNG: 0
> GDLib 2 enabled: 0
> IM5 effects enabled: 0 (Blurring/Sharpening with IM 5+)
> Freetype DPI: 72 (Should be 96 for Freetype 2)
> Mask invert: 1 (Should be set for some IM versions approx. 5.4+)
> File Formats: gif,jpg,jpeg,tif,bmp,pcx,tga,png,pdf,ai
> Warning: Mismatch between the version of ImageMagick () and the 
> configuration of [GFX][im_version_5] (im5)
> The last warning appears even if I change to im6. Any ideas where to go 
> or just a mystical incompatibility..?
> Katja

More information about the TYPO3-english mailing list