[Typo3] Upgrade to 3.8 causes RTE table html to be displayed as text

Christopher bedlamhotel at gmail.com
Fri Jul 1 18:51:00 CEST 2005


On 01/07/05, Lyle E. Dodge <lyle.dodge at wwc.edu> wrote:
> Hash: SHA1
> Christopher,
> > Sounds like you've got a case of htmlspecialchars() on
> > your hands. Maybe try setting
> >
> > RTE.default.proc.htmlSpecialChars = 0
> >
> > ...in page TSconfig [1].
> Hmm...didn't seem to do the trick.  I checked the reference page you
> linked and tried a few options, like putting it in the usergroup TS
> Config, and such, but no luck.

Well, it definitely should be in PAGE TSconfig, not USER... Did you
try it in the TSconfig box in the page header of your root page?

> I really don't think this has to do with the RTE.  Since I can remove
> the HTMLAreaRTE and I get the same result. 

It sure sounds RTE related somehow or other; your content is getting
htmlspecialchar-ed by an RTE transformation, and you don't necessarily
have to have an RTE working to have transformations - try <LINK
http://www.typo3.org>Typo3</LINK> in a text content element when the
RTE is not installed...

> I don't know the full
> workflow of content from the time it comes from the database and renders
> to the FE...but if I look in the database I see clean perfect code
> (regular tags <td> and such) *but* when it renders it turns the stuff
> into the html entities.  Keep in mind this is _just_ for table related
> tags (so far, table, tbody, tr, and td but I suppose it might do it for
> the less popular th too).

It's complicated; apparently html entities are converted to characters
going IN to the db, and from characters coming OUT (see
RTE.default.proc.dontUndoHSC_db in Page TSconfig docs [1]).

In any case, looking on the same page makes me thing that you may need to try:

RTE.default.proc.dontHSC_rte = 1

Incidentally, I _think_ it's Page TSconfig (it might be 'User' or
both) that is not necessarily unset by removing a previously set
value. You may need to explicitly unset previous settings. If you
check the 'Configuration' part of the 'Tools' module in the BE, you
can see Page and User TSconfig in nice, easy to read trees. If the
setting above still doesn't help, have a look through the tree and
look for 'HSC'. Since you have two installs, one with and one without
the problem, it'd also be worth comparing the tree views in the two
different installations to see if there are any suspicious

> > By the way, if it helps, is there a cash option for the prize? ;-p
> Certainly!  When I get it working I'm happy to send someone a little
> "e-cash" as a thank-you.

I was kidding ;^)


[1] http://typo3.org/documentation/document-library/doc_core_api/Page_TSconfig-1/

More information about the TYPO3-english mailing list