[Typo3] $conf Array in Plug-ins is almost empty

Sauerborn, Timm Timm.Sauerborn at arvinmeritor.com
Fri Dec 2 14:36:51 CET 2005

Hi Dmitry,

thank you for the quick response. I tried to insert the plugin.tx_bla =
USER(_INT) into the TS-Setup (cleared cache, even tried to put it in
TS-Constants and also used all "writing"-styles - like tx_blabla_pi1,
tx_bla_bla_pi1, and so on) of my template but nothing changed :( 

I also used the TS Object Browser and it displays all settings just fine...
But even if I use the Object Browser to change some default settings, they
somehow wont get "published" to the plugin when it's called... It's no
matter, which extension it is, they all have an empty $conf-Array. Weird :/

Therefore all the plug-ins did work in the past, somehow they just stopped
to the other day :/
The bad thing is, I can't upgrade to v3.8 because of some extensions. But
anyway, I might have to since "some" extensions not working is a lot better
then no extension's working, lol

Thanks a lot, Timm



>> Sauerborn, Timm wrote:
>> I've noticed a strange behaviour in my front-end-plugins. 
>> Unfortunately no Plug-in does work anymore because the only value 
>> which is commited as $conf-Array to the main-Function of any plug-in 
>> is: userFunc. Anyone has an idea, how to resolve this issue?
>> I already searched over and over, but the only posts I have found 
>> about that are unanswered so far...
>> I'm using TYPO3 3.7.0 on an Apache-WebServer (Windows) and mySQL 4.0

> Take a look how your plugins define their TS setup. It should be named as
plugin.tx_XXX and should always include a line similar to:

> pligin.tx_XXX = USER

> (or USER_INT). If this line is missing you may see the effect you
described. At least it was so with 3.7.0 for me.

> Dmitry.

More information about the TYPO3-english mailing list