[TYPO3-UG Italy] problema login be dopo trasferimento

Luca Mastrobuono luca-mastro at libero.it
Sat Dec 31 17:05:29 CET 2011


Ciao,
può sembrare scontato, ma hai provato a vedere il valore in md5 della
password di amministrazione sulla macchina unix?
Questo valore cambia da macchina a macchina per cui potrebbe esserci una
differenza nella codifica...

Buon anno,

Luca

Il giorno ven, 30/12/2011 alle 14.21 +0100, letsjump ha scritto:
> Buongiorno e auguri a tutti!
> 
> Dopo aver trasferito un sito basato su typo3 4.5.10 sul server unix di
> un nuovo provider, allineato il db, cancellato i file temporanei ecc
> tramite l'install tool, non riesco più ad entrare nel back-end (il
> login riporta: your login attempt did not succed - Make sure to spell
> your username and password correctly, including upper/lowercase
> characters)
> 
> Ho abilitato la scrittura del log su file e mi riporta:
> 
> 30-12-11 13:43 - Core: Error handler (BE): PHP Warning:
> session_start():
> open(/var/lib/php/session/sess_4rshdif38pl6mn32hpaujb45e0, O_RDWR)
> failed: Permission denied (13) in
> /var/www/vhosts/miosito.it/httpdocs/t3lib/class.t3lib_userauth.php
> line 1303
> 30-12-11 13:43 - Core: Login-attempt from 93.56.62.53 (), username
> 'miousername', password not accepted!
> 30-12-11 13:43 - Core: Error handler (BE): PHP Warning: Unknown:
> open(/var/lib/php/session/sess_4rshdif38pl6mn32hpaujb45e0, O_RDWR)
> failed: Permission denied (13) in Unknown line 0
> 30-12-11 13:43 - Core: Error handler (BE): PHP Warning: Unknown:
> Failed to write session data (files). Please verify that the current
> setting of session.save_path is correct (/var/lib/php/session) in
> Unknown line 0
> 
> Versioni di php e mysql sui due server sono allineate.
> 
> Il php_info provvisto nell'install tool specifica questi due valori
> per la direttiva "session.save_path":
> local value: /var/www/vhosts/miosito.it/httpdocs/typo3temp/sessions84cf84d3efc8e62be2eccd
> master value: /var/lib/php/session
> 
> stranamente però creando autonomamente un file php_info nella stessa
> directory, il local value della stessa direttiva corrisponde al master
> value (/var/lib/php/session).
> 
> Inoltre, creando un file php nella stessa directory con un istruzione
> session_start(); essa funziona perfettamente, senza riportare errori
> di alcun genere e memorizzando correttamente le variabili di sessione.
> 
> Dove potrebbe stare il problema?
> 
> Scusate ma ne sto uscendo pazzo... c'è qualcuno che riesce a darmi una dritta?
> 
> ciao,
> 
> Gianpaolo
> _______________________________________________
> TYPO3-UG-Italy mailing list
> TYPO3-UG-Italy at lists.typo3.org
> http://lists.typo3.org/cgi-bin/mailman/listinfo/typo3-ug-italy




More information about the TYPO3-UG-Italy mailing list