[Typo3-typo3org] Debugging Log

Kasper Skårhøj kasper2005 at typo3.com
Sun Apr 10 13:43:28 CEST 2005


Hi Robert,

It might not be caching in 3.8.0 but rather an unfortunate thing in
realurl - try to disable realurl to make sure it really is a caching
thing.

Hint: Realurl has a way to handle cHash values where it will store them
in a separate table associated with the Speaking URL simply in order to
not show it in the URL path and that might fail in some cases. This
could be one.

- kasper


On Sat, 2005-04-09 at 16:17, Robert Lemke wrote:
> Hi folks,
> 
> this is the log of a debugging session I had together with Jan-Hendrik on
> the phone. Together we tried to find out why TYPO3.org was freaking out the
> last 4-5 days.
> 
> 10.04.2005
> 
>  13:00   Announced maintenance on front page and disabled documentation 
>          section
>  13:14   PHP error log throws this error about twice a second:
> 
>          [error] PHP Fatal error:  Cannot redeclare class t3lib_div         
>          in /www/htdocs/_data/typo3.com/typo3_src-3.8.0-dev-cvs/t3lib/class.t3lib_div.php  
>          on line 209
> 
>          seems like some extension tries to include t3lib_div with require 
>          instead of require_once. Because RTE HTML area also has a require
>          in the spellchecker module, deactivated RTE HTML area.
> 
>  13:25   As a workaround changed the require into require_once in 
>          tslib/index_ts.php. The error messages stop.
> 
>  13:30   Created new TYPO3.org account and consultancy entry. Seems to work
>          fine.
> 
>  13:37   Still some errors in PHP error log:
> 
>          [error] PHP Warning:  Cannot add header information - headers 
>          already sent by (output started 
>          at /www/htdocs/_data/typo3.com/typo3_src-3.8.0-dev-cvs/t3lib/class.
>   t3lib_db.php:979)in /www/htdocs/_data/typo3.com/
>   typo3_src-3.8.0-dev-cvs/typo3/sysext/cms/tslib/class.tslib_fe.php 
>          on line 2430
> 
>          disabled extensions section to reduce load, TER still works via EM
> 
>  13:42   Checked the site. After clearing all caches I receive TYPO3_DB 
>          debug messages complaining about duplicate keys in the cache table.
> 
>          Installed phpMyAdmin.
> 
>  13:50   Clearing typo3temp/ cache
> 
>  14:10   Documentation section still shows a different page on each reload
> 
>  14:55  Downgraded to TYPO3 3.7.0 - everything works now. 
> 
> One symptom was this: Access typo3.org/documentation/. With luck you saw the
> documentation main page. Reload. You see a random page of one of the
> manuals. Reload. A different random page etc.
> 
> We found out that ther must be a bug in caching part of the TYPO3 3.8.0 CVS
> version we used. It was not the most current version so we'll have to see
> if Kasper changed something in the meantime.
> 
> If you access the documentation section (typo3.org/documentation/) without a
> cHash, it shows random pages. If you use the cHash, it shows the correct
> page. Some other weird side effects also appeared, like TYPO3_DB debug
> messages warnining about duplicate keys in the pages cache table.
> 
> For now I switched back to 3.7.0 again. Jan-Hendrik made a copy of TYPO3.org
> and after we found out what the problem with the 3.8.0dev caching mechanism
> is, we will try again to make an upgrade on the TYPO3.org copy.
> 
> If we can get TYPO3.org running with 3.8.0, we can enable the cache headers
> functionality and that will give us a huge performance boost - at least
> that is what we expect.
-- 
- kasper

*******************
Happy new year! - My email address is now: 

		kasper2005 at typo3.com 






More information about the TYPO3-team-typo3org mailing list