[TYPO3-core] PHP version requirement

Michael Stucki michael.stucki at typo3.org
Mon Mar 4 17:35:49 CET 2013

Hi Helmut,

> Some Facts:
> * 6.0 runs perfectly on PHP 5.3.0 if no extensions are involved
> * 6.0 runs perfectly on PHP 5.3.0 if extensions are used that are
>   desinged for 6.0 (using namespaced class names)
> * 6.0 runs perfectly on PHP >= 5.3.7 with old extensions using old
>   class names
> * 6.0 runs fine on PHP < 5.3.7 even with old Extensions, but the
>   compatibility layer (which is doing a parsing and rewriting of PHP
>   Code on the fly) is (currently) not good enough to catch all edge
>   cases.

Thanks for the overview. I already came to the same conclusion and don't
think that we could have done much different regarding 6.0.

It runs generally fine, except that some old extensions might need small

> My conclusion:
> The version requirement was set to PHP 5.3.7 because it is the version
> which users will expect the least problems with. It isn't a hard
> requirement (exit in bootstrap), because there are valid cases where PHP
> 5.3.0 is fine for TYPO3 6.0.


> The alternative would have been to leave the official PHP requirement at
> 5.3.0 and dealing with complaints of users who have no problem at all
> updating their PHP version or OS to meet a higher requirement.
> You can blame me for not communicating this properly, but I still think
> it is the right decision.

I'm not blaming anyone! Otherwise I could also blame myself for not
reporting this earlier.

Anyway, it's fine for me regarding 6.0. The discussion however has
turned into a general debate wether or not to consider major Linux
distributions for our requirements.

If we all agree that this is important and we do our very best to stay
compatible with Debian, Ubuntu, CentOS and RHEL, then I'm fine with it.

Greetings, Michael

More information about the TYPO3-team-core mailing list