[TYPO3-core] PHP version requirement

Stefan Neufeind typo3.neufeind at speedpartner.de
Sun Mar 3 19:46:27 CET 2013

On 03/03/2013 06:58 PM, JoH asenau wrote:
>> Who said it was "ignored so easily"? Take a look at that
>> before-5.3.7-compatibility class. The crazy rewriting was create just to
>> work around the PHP bug. A lot of time was spent to find a fix for the
>> include issue, but if you can't find a solution and many later versions
>> (we're now at 5.3.22!) don't have that issue there comes moment when you
>> have to choose between not including a compatibility layer at all, not
>> doing the namespace operation at all and setting a requirement version.


> Especially in enterprise environments you won't always get the cutting
> edge version of your favorite OS, PHP and other necessary software. This
> is due to the fact that there are many other pieces of software running
> in the same environment on umpteen thousands of servers and
> workstations, with some of them taking Millions of Euros to have them
> working on latest OS versions. This is something that must be taken into
> account _before_ implementing major changes to the core of a CMS that
> claims to play on enterprise level.

Well, maybe for an enterprise-ready distribution you could kindly ask
your vendor to provide a 5.3.4 or whatever with fixes backported?
Imho those are actually unfixed issues in a distribution that claims to
be enterprise-ready, sticks to old software but also doesn't care about

Otherwise, maybe just stay at 4.7 for the time being? The number-change
to 6.0 of course included that there were major changes ahead (otherwise
it would have been long planned 4.8).

While in general there was of course some truth in your words (gap
between rules and reality etc.) I don't agree in regards to the
PHP-version requirement. It runs on 5.3.x - just a more recent one.


More information about the TYPO3-team-core mailing list