[TYPO3-core] PHP version requirement

Wouter Wolters typo3 at wouterwolters.nl
Fri Mar 1 00:19:38 CET 2013

Hi Micheal,

AFAIK the requirement is set to 5.3.7 because there are some issues in 
lower versions which are related to the namespace change. These have 
been tackled in 6.0, to also work with 5.3.3. But it can happen that it 
gives problems (there are no known issues to my knowledge).

So 5.3.7 is a version that is guaranteed to work with 6.0.
Nevertheless 5.3.3 is also working.

Greetz Wouter
Op 1-3-2013 0:08, Michael Stucki schreef:
> Hi folks,
> I have been asked about the minimum version required for TYPO3 6.0.
> According to the download page, it requires PHP 5.3.7 [1].
> However, the PHP version used by Debian Stable is currently 5.3.3, and
> the guy who created this issue is very right in my opinion that this
> should be a major requirement [2].
> I made some tests and installed an introduction site on a fresh Debian
> Squeeze. As far as I can see, there are no problems.
> I remember that there was one such issue, however it has been fixed
> already a while ago: https://review.typo3.org/#/c/17180/
> So, do you know about any remaining issues, or can we change that
> version requirement and clarify that TYPO3 6.0 runs fine with Debian
> Squeeze?
> Thanks for your feedback!
> Greetings, Michael
> [1] http://typo3.org/download
> [2] http://forge.typo3.org/issues/44378

More information about the TYPO3-team-core mailing list