[TYPO3-core] RFC: Bug 5094: Record alt_label doesn't get processed

Thomas Hempel thomas at work.de
Mon May 7 16:53:15 CEST 2007


> Your problem description doesn't match any bug report I have found.
> #4943 seems to be solved already (extra commas in the output). In your
> reference #5094 we have another problem, which is also solved in your
> patch, which is calling getProcessedValue to for example resolve
> unixtimes to dates when printing out the label. This fix will also close
> #5483, which I had fixed in TD33 but forgot about it after some hours/beers.
> So if you can point us to the bug report, or to a simple way of
> reproducing the error (example TCA, sample entry, expected and actual
> output), we could get that bug fixed. I cannot currently understand
> exactly what the problem is.
The bugreport is exactly for the problem that is fixed with the patch.

If you set a label_alt in the TCA *and* label_alt_force the alternative label is only rendered if 
you also enter something for the "normal" label field.

	'label_alt' => 'subtitle',
	'label_alt_force' => 1,
	'label' => 'title',

If you create a new page and fill in an value for "subtitle" but not for "title" you won't see the 
correct label. Without the patch "[no title]" will be printed out instead of the value of "subtitle".

I hope the problem is clearer now!?


More information about the TYPO3-team-core mailing list