[TYPO3-core] RFC: C#6859 Clean up/Feature of db_new.php. Adding flexible newWizards

Francois Suter fsuter at cobweb.ch
Sun Dec 9 22:20:27 CET 2007

Hi Malte,

I started looking at your proposal. The code works but there's a lot to 
check and I haven't time right now to make a full review. I do have a 
couple of remarks though, so I thought I would spell them out already:

- I find the proposed update to the Core API doc a bit confusing, 
especially about the "level" property. If I find the time to test your 
RFC properly I'll try to come up with suggestions.
- In the same doc, I must admit I don't understand the following 
sentence "You can also group tables of an extension, so the list gets 
more readable" and there's no example to explain it.
- And a small thing. The description for the new key "hideNewTable" 
appears twice.
- Would it be possible to move the new page wizard to an outside class, 
similar to the new content wizard, so as to be more coherent? That way 
the "self" value could be dropped for property "path".
- I understand that the "Page (after)" is a special case, but I find it 
disturbing to have it marked as a wizard, since it doesn't lead to the 
wizard when you click on it. IMO the icon should a normal page icon.
- On the contrary the bottom-most item "Create a new page" does lead to 
the wizard, but it doesn't appear in your list of newWizards in the TCA.

Apart from that I am globally very positive about the concept and I hope 
I will have time to dig deeper into it.



Francois Suter
Cobweb Development Sarl - http://www.cobweb.ch

More information about the TYPO3-team-core mailing list