[TYPO3-templavoila] TV 1.4.X issue

Xavier Perseguers typo3 at perseguers.ch
Wed Dec 2 08:18:57 CET 2009


> I'm not sure where that comes from but I tried a TV update from 1.3.7
> to 1.4.1 on a test server and found that my mapping data would not
> survive the DB scheme update
> ALTER TABLE tx_templavoila_tmplobj CHANGE templatemapping templatemapping blob;
> As soon as I change that field back to mediumtext, everything works
> fine again.
> I suspect that this is related to my MySQL setup somehow. I'm using
> MySQL 5.0.51 and the tx_templavoila_tmplobj is in utf8_general_ci
> encoding.
> Has anyone else run into a problem like this?

Yesterday I ran into a similar issue but as I switched back and fore between 1.3.7 and 1.4.1 and under a little time pressure I thought blob was for 1.3.7.

My problem was not related to MySQL but to an Oracle database. When using DBAL to connect to the database, mediumtext is mapped onto a CLOB while blob stays as this, BLOB. I could not save mapping 
anymore as Oracle reported "expected CLOB got BLOB" but I should investigate a bit more, perhaps a cache effect as BLOB should be supported as well.

Changing it back to mediumtext is not a problem when using DBAL and all layers are properly configured to use UTF8. But if not, you'll discover that whenever your database connection (for instance) is 
not using UTF8 (e.g., after a reboot while not having proper environment variable for Oracle), your mapping will be "lost" => not unserializable anymore.


Xavier Perseguers

One contribution a day keeps the fork away

More information about the TYPO3-project-templavoila mailing list