[TYPO3-templavoila] strange behaviour after update

Steffen Kamper info at sk-typo3.de
Fri Nov 21 17:06:11 CET 2008


Dmitry Dulepov schrieb:
> Hi!
> Steffen Kamper wrote:
>> today i saw a very strange behaviour after update.
>> The former site used
>> * php4
>> * TYPO3 3.8.1
>> * TV 0.3.0
>> After update to
>> * php5
>> * TYPO3 4.2.3
>> * TV 1.3.7
> Well, you risked a lot but doing such a huge upgrade. It should be
> one thing at at time, verifying after each step.

atm TV 0.4.0 is running, there is only a small problem with php-errors 
because empty sections in FCEs, but these can be deleted and it's 
working again.

>> Following things happened:
>> BE: everything is fine, mapping of all templates is fine, preview is fine
>> FE: all not mapped elements are shown without any HTML!
> Do you have strip_tags somewhere in <stdWrap> in DS?

no, DS looks normal. I always "resaved" DS/TO to be sure, but it doesn't 
solved it.
>> A short debug in pi1 shows (function processDataValues):
>> $dataValues[0] has the HTML of unmapped elements
>> after the function this is cleared.
>> commenting out the line
>> $LP[$key] = $DSelements[$key]['tx_templavoila'];
>> leaves the $dataValues[0] unchanged, but then all mapped data is loosed :D
> Hmmm. Why would you comment it? It is there for a reason. The right
> way would be to examine your DS/TO first. May be resave it with a
> new version of TV. Debugging code is the very last step to do.

this was only testing, nothing for let it commented out. I only tried to 
find out where the HTML got loosed.

vg Steffen

More information about the TYPO3-project-templavoila mailing list