[TYPO3-templavoila] Gifbuilder: image field does not contain proper path

Bart Veldhuizen [V-INT] bart at v-int.nl
Mon May 28 13:28:23 CEST 2007


I'm trying to use a GIFBUILDER object in an FCE. Everything works  
fine, but I run into a snag when I try to use a file from an Image  
Field in the FCE. Here's the code that I call from the FCE:

lib.graphic_test = IMAGE
lib.graphic_test {

	file {
		XY = 420,204
		format = jpg

		10 = IMAGE
		10 {
			file.field = field_image_file

What happens is that file.field will now contain the name of the  
image file (say, 'kids.png'), but it does not include the proper path  
( 'uploads/tx_templavoila'), so the GIFBUILDER object can't do its  
job. I tried wrapping the file object with the proper path, but this  
does not seem to work. Any ideas on how I could fix this?



Bart Veldhuizen, Veldhuizen Interactive.  Tel: 06-420 67 330
website analyse & advies | content management systemen

More information about the TYPO3-project-templavoila mailing list