[TYPO3-templavoila] Problem with adding new elements

Dmitry Dulepov dmitry at typo3.org
Thu Jun 21 11:53:40 CEST 2007


Firsts, please, always write your full real name (this is what our 
mailing list rules kindly ask to do from everyone).

ck at ckworld.ch wrote:
> i tried to build a language menu with THE languageMenu.php (original)
> but it doesent work the FE shows nothing.
> my TS Script Setup look like:
> lib.langMenu = PHP_SCRIPT
> lib.langMenu.file = fileadmin/media/scripts/languageMenu.php


> this one works well. I see the "TEST" in FE. i dont known the reason why the 
> php script not shown. i already tried with a simple echo in the php file, 
> doesnt work...after i changed the type of editing type from typoscript to 
> ce, ce doesnt work . the only thing which works is a "Rich text editor for 
> bodytext".

"ce" will not work because you still have 
<TypoScriptObjPath>lib.langMenu</TypoScriptObjPath> in the DS and it 
overrides anything else (except RTE).

It seems that your file is not included at all. Are you sure it has no 
PHP errors and it includes any files so that they are relative to site root?

Dmitry Dulepov
TYPO3 freelancer / TYPO3 core team member
Web: http://typo3bloke.net/
Skype: callto:liels_bugs

More information about the TYPO3-project-templavoila mailing list