[TYPO3-english] specials character inside RTE doesn't work !

Alessandro Tuveri at at uniud.it
Wed Mar 28 10:33:18 CEST 2012

Hi Daniel Tâche
I battled for a long time vs utf8 and TYPO3CMS.

Please do this:

* set localconf.php with SET names utf8; and forceCharset uf8 for BE

* verify that all conf for object PAGE are defined for utf8 (like  
suggested by Xavier)

* run phpmyadmin

* print the table list so I can know how is the collation and  
configuration for each table (I can't exclude that there is mix of  
latin1 and utf8)

* using phpmyadmin access to a table (ie. tt_content) and open a  
record of content (ie. text) where there is stored some text with  
accented letters; edit
it and verify if there is some "strange characters" instead of  
accented (ie: A with a tilde over, etc.)

* render the page and verify what you can see inside - charset is  
correctly recognized as utf8 by navigator (you can see this with  
Mozilla, search within the menus)

* see the source of the page. Do you see some strange chars or the  
accented letters are OK

Send me the report.

Maybe that, if you see strange characters -- using phpmyadmind or  
looking for this in the source of your page - that your MYSQL database  
wrongly stored some accented letters. If this is your problem don't  
worry; I'll send you the instructions and a little shell program to  
run under linux to convert the chars (off I was desperately so I made  
myself this little program...).


if you see some strange c
<daniel at comeandsee.ch> ha scritto:

> Hi all,
> I'm trying to insert special character in RTE but I've got an error message:
> 102: These fields are not properly updated in database: (bodytext)  
> Probably value mismatch with fieldtype.
> My website is in utf-8, I've follow this very good tutorial :  
> http://xavier.perseguers.ch/tutoriels/typo3/configuration/utf-8.html
> I've tried many different RTE configuration like:
> RTE.default.proc.dontHSC_rte = 1
> entryHTMLparser_db.htmlSpecialChars = 0
> exitHTMLparser_db.htmlSpecialChars = 0
> But no way !
> I've tried an old configuration with [SYS][setDBinit] = SET NAMES  
> utf8;CHARSET utf8;
> And it works but my website is a mess as character are double times in utf-8
> Anybody has an idea ?
> Thanks in advance
> _______________________________________________
> TYPO3-english mailing list
> TYPO3-english at lists.typo3.org
> http://lists.typo3.org/cgi-bin/mailman/listinfo/typo3-english


Servizi WEeb d'Ateneo
Universit? degli Studi di Udine
tel. ufficio 0432-558904
Homo sine pecunia est imago mortis

SEMEL (SErvizio di Messaging ELettronico) - AINF, Universita' di Udine

More information about the TYPO3-english mailing list