[Neos] [Installation Blocker] Composer and php-binary on webspace

Robert Chwistek robert at chwistek.at
Thu Nov 13 12:50:36 CET 2014

Hi Hendrik,

I was facing the same problem last week and got around it.

Assuming you have access to the git configuration, you could rewrite the
global url setting.
Use "git config" to achive it:

git config --global url."https://".insteadOf git://

After rewriting the global url the installation worked in my case.

the following post helped me out:

kind regards,

On 2014-11-11 10:10:33 +0000, Hendrik Frahmann said:

> Hello,
> on Twitter you are asking to report installation blockers.
> I have tried to install Neos on a webspace with composer where I don't 
> have full server access.
> I only have got a limited ssh access.
> 1. It seems that the git-port (for git://) is blocked. Is it possible 
> to install it over http ?
> ---------------
>   git.typo3.org[0:]: errno=Connection refused              
>                       git.typo3.org[0: 2a01:198:1:1::151]: 
> errno=Network is unreachable                                            
>                                                        fatal: unable to 
> connect a socket (Network is unreachable)  ---------------
> 2. The other thing is, that PHP does not have access to /bin/php (or 
> /usr/bin/php) so the Neos setup cannot be done.
> Thanks :-)

More information about the Neos mailing list