[Neos] TYPO3 Neos 1.1.2 | Out of memory

Michael 9pm at gmx.net
Fri Nov 7 15:26:26 CET 2014

Quote: Philipp Gampe (pgampe) wrote on Fri, 07 November 2014 14:56
> Hi Michael,
> Michael wrote:
> > Fatal error: Out of memory (allocated 39321600) (tried to allocate 7168 
> bytes) 
> >  But in my php.ini i set memory_limit to "2048M"
> It looks more like 40M ;)
> Make sure to set the limit in the correct php.ini file. There is at least 
> one file for the HTTP context and one file for the CLI context.
> I guess you missed one or you used to wrong one altogether.
> Best regards
> -- 
> Philipp Gampe  PGP-Key 0AD96065  TYPO3 UG Bonn/Köln
> Documentation  Active contributor TYPO3 CMS
> TYPO3 .... inspiring people to share!

Hi Philipp,

thanks for your answer! :)
I know, but i thought more is better :D

Ok, it's quite a little bit confusing. I have a php.ini in my Webroot (/Web) and a php.ini under the flow root. Both are containing the same settings. On my server runs PHP 5.5.18. When i'm on the command line and i enter [php -v] it says "PHP 4.4.9". That's why i always prefix the ./flow commands with "/usr/bin/php5.5-cli", because then the correct PHP 5.5 version will be used. And when i run flow compile (with this prefix) on the command line, it works. I also set [phpBinaryPathAndFilename] and [subRequestPhpIniPathAndFilename] in my Settings.yaml file.

        phpBinaryPathAndFilename: '/usr/bin/php5.5-cli'
        subRequestPhpIniPathAndFilename: '/kunden/homepages/xxxx/xxxxxxx/htdocs/php.ini'

I don't know what else i could do. :(

More information about the Neos mailing list