[Neos] [Team] Raising PHP requirement for Neos 1.2 to PHP 5.4

Marc Neuhaus apocalip at gmail.com
Fri Jun 27 13:41:11 CEST 2014

My votes would be as well, to bump Neos now, and probably bump Flow with


2014-06-27 13:12 GMT+02:00 Robert Lemke <robert at typo3.org>:

> Hi Jigal,
> On 26. Jun 2014, at 21:20 , Jigal van Hemert <jigal.van.hemert at typo3.org>
> wrote:
> > One thing that we encountered with TYPO3 CMS is the LTS version of
> various OS distributions. Debian Squeeze will get security updates until
> february 2016. Another peculiarity of these distributions is that they
> often stick with the version of various tools that they originally shipped.
> It looks like Debian Squeeze will stay with PHP 5.3  (currently version
> 5.3.3-7+squeeze19).
> > They backport all patches for 5.3.x and most likely they will even
> continue to do so with patches for 5.4 which do not introduce features.
> >
> > People will need to upgrade their OS to be able to move to newer PHP
> versions; most sysadmins will not want to install packages that are not
> from the stable repository and will thus stay with something that is
> identified as PHP 5.3.
> >
> > (LTS versions seems to limit progress in software quite a bit IMO)
> yes, you're right, I had that in mind, too.
> So unless we really need it, I would _note_ bump the PHP version for Flow
> yet and keep PHP 5.3 compatibility for the next version at least (Flow
> 2.3). But since Neos is rather new and we don't expect many people
> complaining about it, I'd say we raise the requirement to 5.4.
> If needed, let's discuss in a separate thread if or when Flow should use
> 5.4.
> Cheers,
> Robert
> _______________________________________________
> Neos mailing list
> Neos at lists.typo3.org
> http://lists.typo3.org/cgi-bin/mailman/listinfo/neos

More information about the Neos mailing list