[Neos] Error occured during setup (beta2/beta3)

Aske Ertmann aske at moc.net
Tue Jul 22 19:28:35 CEST 2014

Hi Uwe

> I encountered exactly the same problem as Rick. I followed your advice, but that did not seem to help at first. NodeTypes was reported as installed.
I actually experienced the same myself recently, where the TYPO3.Neos.NodeTypes package was marked as “active” but the problem still occurred. I can’t remember how I solved it, but it didn’t make any sense so I think I removed Data/Temporary/ to clear the cache.

> And direct import did not seem to work either:
> # ./flow site:import --package-key Typo3.neosdemotypo3org
> Error: During the import of the "Sites.xml" from the package "Typo3.neosdemotypo3org" an exception occurred: Error: Package "Typo3.neosdemotypo3org" is not active.
This is actually a valid error message because the package key is "TYPO3.NeosDemoTypo3Org" and not "Typo3.noesdemotypo3org”, but probably wouldn’t have worked anyway if it was the NodeTypes package causing problems.

> However, after that the setup ran through correctly and I have a working demo site. Before that, setup had always complained that Kickstarter was not installed - but it was and the latest version. Setup suggested using composer to install Kickstarter, but this is what I got from composer:
> # composer require typo3/neos-kickstarter
> Please provide a version constraint for the typo3/neos-kickstarter requirement: 1.1.*
> /composer.json has been updated
> Loading composer repositories with package information
> Updating dependencies (including require-dev)
> - Updating typo3/neos-kickstarter (1.1.0-beta3 => 1.1.x-dev 827c4cc)
>                                                                                                                                      [RuntimeException]                                                                                                                             The .git directory is missing from Packages/Application/TYPO3.Neos.Kickstarter/, see getcomposer.org/commit-deps for more information 
This error sounds like a previous installation of the package went wrong, because it would happen if the folder already exists but lacks the .git folder. Again hard to tell without more information.

> Nevertheless when I re-ran setup it worked when before I would always encounter the problem seen by the OP.
> Could it be that running "./flow package:list" solved the issue by updating a local cache?
Not sure, but could be. Or it rewrote the PackageStates.php or similar. If it’s possible to reproduce on a clean install consistently we of course need to look further into the matter.

Best regards

More information about the Neos mailing list