[Neos] Error occured during setup (beta2/beta3)

Uwe Trenkner mail2000 at trenkner.net
Tue Jul 22 11:09:33 CEST 2014

Hi Aske,

I encountered exactly the same problem as Rick. I followed your advice, but that did not seem to help at first. NodeTypes was reported as installed.

And direct import did not seem to work either:
# ./flow site:import --package-key Typo3.neosdemotypo3org
Error: During the import of the "Sites.xml" from the package "Typo3.neosdemotypo3org" an exception occurred: Error: Package "Typo3.neosdemotypo3org" is not active.

However, after that the setup ran through correctly and I have a working demo site. Before that, setup had always complained that Kickstarter was not installed - but it was and the latest version. Setup suggested using composer to install Kickstarter, but this is what I got from composer:

# composer require typo3/neos-kickstarter
Please provide a version constraint for the typo3/neos-kickstarter requirement: 1.1.*
/composer.json has been updated
Loading composer repositories with package information
Updating dependencies (including require-dev)
  - Updating typo3/neos-kickstarter (1.1.0-beta3 => 1.1.x-dev 827c4cc)
  The .git directory is missing from Packages/Application/TYPO3.Neos.Kickstarter/, see getcomposer.org/commit-deps for more information 

Nevertheless when I re-ran setup it worked when before I would always encounter the problem seen by the OP.

Could it be that running "./flow package:list" solved the issue by updating a local cache?

Maybe the information above can help improve the setup so that it works for more people.


More information about the Neos mailing list