[Neos] Taking l10n for a test drive

Lienhart Woitok Lienhart.Woitok at netlogix.de
Sun Feb 9 11:54:47 CET 2014

Hi Kerstin,

thanks for your hints, they work great.

Now I got it up and running. I can also confirm that publishing a changed node name does not work. Interesting is, that when I first published that (via publish all changes), I got a success message, but the change was not published. After that I suddenly had 27 changes to publish, which I think were all content elements on that page (I renamed features/multiple-columns). When publishing all those changes I got the same exception.


Lienhart Woitok

Telefon: +49 (911) 539909 - 0
E-Mail: Lienhart.Woitok at netlogix.de
Website: media.netlogix.de

Geben Sie Cyber-Kriminellen keine Chance
Lückenloser Schutz mit Security-Lösungen von Sophos: Erfahren Sie, wie Sie Ihr Unternehmen wirksam schützen und gewinnen Sie einen Boomball Pro Mini-Lautsprecher:

netlogix GmbH & Co. KG
IT-Services | IT-Training | Media
Neuwieder Straße 10 | 90411 Nürnberg
Telefon: +49 (911) 539909 - 0 | Fax: +49 (911) 539909 - 99
E-Mail: info at netlogix.de | Internet: http://www.netlogix.de

netlogix GmbH & Co. KG ist eingetragen am Amtsgericht Nürnberg (HRA 13338)
Persönlich haftende Gesellschafterin: netlogix Verwaltungs GmbH (HRB 20634)
Umsatzsteuer-Identifikationsnummer: DE 233472254
Geschäftsführer: Stefan Buchta, Matthias Schmidt

Von: neos-bounces at lists.typo3.org [neos-bounces at lists.typo3.org]" im Auftrag von "Kerstin Huppenbauer [k.huppenbauer at web.de]
Gesendet: Sonntag, 9. Februar 2014 10:41
An: neos at lists.typo3.org
Betreff: Re: [Neos] Taking l10n for a test drive

Hi Lienhart,

> Exception while rendering
> landingPage<TYPO3.Neos:Page>/
> body<TYPO3.TypoScript:Template>/
> parts/
> mainMenu:
> RoutePart::getValue() must return a string after calling RoutePart::resolve(), got boolean for RoutePart "TYPO3\Neos\Routing\LocalizedFrontendNodeRoutePartHandler" in Route "TYPO3 Neos :: Frontend :: Homepage". (201402081653497fe9b9)
> I added the Settings to my Settings.yaml file and translated the site with the command from README, but that didn't change anything. Then I did a prune and import according to README and translated the site again, no change.
> I debugged into LocalizedFrontendNodeRoutePartHandler and found out that the line
> $routePath = substr($routePath, 0, strrpos($routePath, ';'));
> in resolveRoutePathForNode() is the cause of the exception. $routePath is an empty string, therefore strrpos returns FALSE. In the end, $routePath is FALSE.
> I then had a look into the database. I noticed the the table typo3_typo3cr_domain_model_nodedimension is empty. That looks wrong to me, but running node:translate doesn't fill this table.
> Do you have any idea what I could now do to get this to run?

I had the same Exception and I think it's because the dimension array
was empty. So I added a default locale to the ContentDimensions in
the Configuration of TYPO3.TYPO3CR and run the import command again.
After that the items in the typo3_typo3cr_domain_model_nodedimension
table were created too.
But the translate command didn't work yet. So I looked at the Behat
Scenario and removed 'mul_ZZ' from the locales array in the
translationContext in the node command controller. After that the
translate command worked for me.

Publishing of Text Changes in both locales worked, but publishing all
changes after editing the node title throws an exception
SQLSTATE[23000]: Integrity constraint violation: 1062 Duplicate entry
'96b61b5f6f2569cd6601c5eb0cfe45d6-live-8416eeb4c41f9f67db354333bb' for
key 'UNIQ_60A956B92DBEC7578D94001992F8FB01'
which is the pathHash

Don't know what's going wrong there - the Behat tests are all successful
and i'm just a Neos newbee...

Greets Kerstin
Neos mailing list
Neos at lists.typo3.org

More information about the Neos mailing list