[Neos] NeosDemoTypo3Org multi-column classes

Jill Peterson jillande at gmail.com
Wed Apr 30 00:01:33 CEST 2014

Greetings Christian,

Sorry for my delay in responding, I didn't notice your reply until now.

I don't have anything extra installed unless it's possible to do so without knowing it. I started over again by deleting the Neos directory and database and beginning fresh with
1. mysql> drop database neos;create database neos character set utf8 collate utf8_general_ci;
2. php composer.phar create-project --no-dev typo3/neos-base-distribution TYPO3-Neos-1.1 1.1.0-beta1
with no reported errors other than several variants of the following, which I assume to be expected.
 Class TYPO3\Flow\Composer\InstallerScripts is not autoloadable, can not call post-package-install script
  - Installing doctrine/lexer (dev-master f12a5f7)
    Cloning f12a5f74e5f4a9e3f558f3288504e121edfad891
3. ./flow core:setfilepermissions me apache apache
4. Follow database setup in neos.demo/setup with MySQL/MariaDB via PDO
and site setup importing "TYPO3.NeosDemoTypo3Org" site
"Your environment is suited for installing TYPO3 Flow!
We are now redirecting you to the setup. This might take 10-60 seconds on the first run, as TYPO3 Flow needs to build up various caches."
"The selected database's character set is set to "utf8" which is the recommended setting."
Create administrator account
Import a site - Select a site* = TYPO3.NeosDemoTypo3Org
Go to the backend, log in as just-created admin
5. In the "Content Collection (main)" of the main page, click the + button to "Create after," choosing two column content. The (two column) content collection is added at the beginning of the collection and displays like there are two areas for content oriented on top of each other (as opposed to next to each other horizontally). Selecting the the newly-created node from the ??content browser?? observe the Columns - Layout = 50%-50% that sets a "-50" class instead of the later 50%-50% selection that uses the -"6" class. Choosing the second 50%-50% and "Apply"ing results in the columns orienting next to each other horizontally as expected.

Since I first posted I also tried updating to the tagged beta 2 in Git and didn't observe a change.

I'm presently using the Webtatic build of PHP 5.4 for RHEL6, but eventually will migrate to the RHSCL build of PHP 5.4 (or 5.5 once it's out of the beta collection). I can try that PHP build instead on another host to see if that makes a difference.
rpm -qa | grep php

Also using the RHEL6 mysql 5.1.73 build. Understanding 5.1 is very old at this point, I could try the RHSCL build of MySQL, which is a 5.5 release, if that might be a factor. I don't suspect this is the problem, however.

I tried disabling opcache in case it has a conflicting configuration.

How can I debug the order the typoscript is loaded?
Looking in the Data/Logs I don't see anything relevant. I can send them, offline, if it's of use. It's only 8k since I haven't done anything but install and log in once.

More information about the Neos mailing list