[Neos] [Poll] Naming conventions on CSS class names

Sebastian Kurfürst sebastian at typo3.org
Wed Oct 9 08:09:39 CEST 2013

Hey Thomas,

thanks for the discussion!

However, I feel that using stuff like "div.htmlAttributes.class" would
be a too-unpragmatic solution currently -- people would expect e.g.
"div.htmlAttributes.id" to work as well, which it wouldn't.

That's why I decided on "className" now (also as result of the doodle
poll) -- we can lateron always use something like the above convention
and deprecate "className", providing even some migration.


More information about the Neos mailing list