[TYPO3-50-general] Naming conventions for user-level settings

Karsten Dambekalns karsten at typo3.org
Fri Sep 12 18:03:19 CEST 2008

Hi Jochen, Robert, everbody.

Robert Lemke wrote:
 > Am 21.05.2008 um 14:16 schrieb Jochen Rau:
 >> IMO there should be some naming conventions like
 >> $c->MyPackage->MyComponent->mySpecialSetting = 'Hello World!';

I used that way for TYPO3CR today, changed the configuration manager a 
little to fit to that and started documenting configuration in the FLOW3 
package documentation (see SVN).

 > However, we should make up some more rules for
 >  - settings which are shared by multiple subpackages
 >  - names for commond settings which reocurr every now and then

That is still open. For common settings I would suggest using a "special 
package key" that is reserved, like, err, "GLOBALS" or something.

Options shared by subpackages (as in subpackages in one FLOW3 package) 
can be named as the developer likes, I think it is hard to come up with 
rules that make sense here. Or did I get the term "subpackages" wrong?


More information about the TYPO3-project-5_0-general mailing list