[TYPO3-english] special character appears with php 5.3

Joydeep Bakshi joydeep.bakshi at infoservices.in
Wed Apr 17 09:38:57 CEST 2013

Dear list,

I am stuck with a site migration which is running with typo3 4.4.7 and
it should be upgraded to 4.7.10

The migration is smooth; the only issue is the special character. As I reached at typo3 4.6.*
it demand php 5.3, and as I allow that with cgi module, the sites get php 5.3 and FE /BE get
special character issue.

I have already tried with following at localconf.php

$TYPO3_CONF_VARS['SYS']['setDBinit'] = 'SET NAMES utf8';

No success.

Also tried adding following at .htaccess

AddCharset UTF-8 .php
php_value default_charset "UTF-8"
php_value iconv.input_encoding "UTF-8"
php_value iconv.internal_encoding "UTF-8"
php_value iconv.output_encoding "UTF-8"
php_value mbstring.internal_encoding UTF-8
php_value mbstring.http_output UTF-8
php_value mbstring.encoding_translation On
php_value mbstring.func_overload 6

No success.

What else is possible ?
Please suggest.

More information about the TYPO3-english mailing list