[TYPO3-english] indexed_search with non western language

Historia newsletter at zimmermann-steinhart.de
Mon Nov 22 09:23:03 CET 2010

Another try with a new dummy. All set to UTF-8 and then imported the 
website with t3d. Nothing changed. Website is perfect but Database 
content ist still not utf8 coded.

So Typo3 is converting the utf8 content to something else. No more idea 
where to search.


Am 19.11.2010 14:36, schrieb Historia:
> Ok, giving up,
> I created a new Database did a iconv from latin to utf8, set all to utf8
> lost practically all my content and put in new content in Amharic.
> The content is still not utf-8 according to webbrowsing with phpmyadmin
> and when I put content directly in the database it is shown nicely but
> neverless not found with the fe search.
> So I have to give up with the Introductionpackage and have another try
> with Dummy. Is there nobody out there with similar problems in Kyrillic,
> Thai or chinese?
> Herbert
> Am 19.11.2010 10:01, schrieb Historia:
>> Hello Stefan,
>> no, doesn't work. The code in the database is stored in another format.
>> I have no idea about the real coding of the entries. Typo3 somehow
>> recodes the entries so they come out as utf in FE and BE, but they are
>> recoded in the database. tt-content and index are the same strange
>> characters.
>> So I think solr will be no option either.
>> Herbert
>> Am 18.11.2010 17:36, schrieb Stefan Frömken:
>>> Hello Herbert,
>>> Have you truncated the cache_*-tables? You can do this with
>>> phpmyadmin-extension.
>>> UTF-8 will be default in TYPO3 4.5.0 at the end of january.
>>> Stefan
>>> Am 18.11.2010 15:21, schrieb Historia:
>>>> Hello Stefan
>>>> did the clidispatch from the backend, cleared the cache and visited
>>>> lots
>>>> of pages. Nothing is found. I have to set up a new website with the
>>>> dummy package to check if there is some other issue about the coding.
>>>> I wonder why not all is utf-8 in the system as default.
>>>> Herbert
>>>> Am 18.11.2010 15:56, schrieb Stefan Frömken:
>>>>> Am 18.11.2010 13:43, schrieb Historia:
>>>>>> Hello,
>>>>>> I made a website with Amharic (Ethiopia) and English. All is based on
>>>>>> the Introductionpackage 4.4.4 with an own template. I have it
>>>>>> local on
>>>>>> Windows and live on a Suse 11 Rootserver.
>>>>>> indexed search is not working with Amharic script.
>>>>>> In the indexing page the amharic script is not coded in the right
>>>>>> way,
>>>>>> however in DB check I can properly search in Amharic with the right
>>>>>> coding.
>>>>>> Database is set to unicode general charset utf-8
>>>>>> [BE][forceCharset] = utf-8
>>>>>> Is there some other issue related to the search?
>>>>>> thanks Herbert
>>>>> It seems that you have installed indexed_search before you have
>>>>> changed
>>>>> Charset. In this case all words were saved with wrong characterset in
>>>>> cache_* tables, but they are correct in tt_content-table and on
>>>>> website,
>>>>> too.
>>>>> If I'm right...than I prefer to truncate all data in cache_* tables
>>>>> and
>>>>> execute scheduler with crawler-task or _cli_dispatch or visit each
>>>>> page
>>>>> manually. But please backup your database first!
>>>>> Stefan

More information about the TYPO3-english mailing list