[TYPO3-english] tagpack: problems since upgrading to 0.12

JoH asenau info at cybercraft.de
Fri Jan 8 13:16:57 CET 2010

>> I only use the default setup (so no additional tables like tt_news)
>> and so I looked in the TSOB and found no configuration for
>> $conf['taggedElements.']['additionalFilters.'][$table.'.'] (as I'm
>> only using pages and tt_content).
>> So my solution was to replace that assignment by
>> if ($conf['taggedElements.']['additionalFilters.'][$table.'.']) {
>>   $filters =
>> $conf['taggedElements.']['additionalFilters.'][$table.'.']; } else {
>> $filters = array(); }
>> and now it works. I get all my results as I want.
> The interesting question is, why it works with 4.2.10 and not with
> 4.3.0
> Will dig deeper and hopefully come up with a new bugfix version today.

Well - it even worked with 4.3.0 in our testing environment, but due to the
fact that there always were some additionalFilter settings available. So
your solution is exactly what is necessary, since the following while loop
should be outside the curly braces of the if clause. I guess this bug has
been introduced during the performance improvements when we replaced the
exec_SELECTgetRows queries to avoid double loops.

So thanx for tracking this down. 0.12.1 will be uploaded immediately.



Wenn man keine Ahnung hat: Einfach mal Fresse halten!
(If you have no clues: simply shut your gob sometimes!)
Dieter Nuhr, German comedian
Xing: http://contact.cybercraft.de
Twitter: http://twitter.com/bunnyfield
TYPO3 cookbook (2nd edition): http://www.typo3experts.com

More information about the TYPO3-english mailing list