[TYPO3] Font not getting resized in gifbuilder menu after OS upgrade

Christopher Torgalson bedlamhotel at gmail.com
Thu Nov 8 19:21:35 CET 2007


On Nov 8, 2007 6:34 PM,  <bstone at firstambank.com> wrote:
> I am having a strange problem with a menu that it is dynamically created in
> a typo3 3.5 environment. I am currently moving an existing typo3
> environment to new Linux systems (for security reasons) so that they can be
> fully patched at the OS level (our current environment is running on RedHat
> 9..
> After moving the typo3 environment it appears that all things are working
> correctly except for a menu that gets dynamically created (I think using
> gifbuilder).
> The menu is getting created correctly in the correct color, but it appears
> that the font is not getting resized at all. In reading about this, I
> recall that for image quality / readability purposes a font first gets
> rendered as an image, then resized, then blended into the new .gif image
> for the menu. The finished image ends up in the "typo3temp" directory.
> Here is an example of a portion of the menu that was created correctly:
> http://www.joeslab.com/m_ad069abf81.gif
> Here is an example of a portion of the menu that was not created correctly:
> http://www.joeslab.com/m_ea6fe6366c.gif
> As you can see the texted never gets resized.
>  I am thinking this is something that can be solved in the configuration
> because it works fine on the other boxes. I just know I am missing
> something.
> Here are the things that I tried so far:
> 1) Tested to make sure "gd" works on the system (It worked fine).
> 2) Tested to make sure "ImageMagick" convert program works as a standalone
> with finding custom fonts (It worked fine).
> 3) Tested to make sure "ImageMagick" works in the web environment and can
> write to the appropriate temp directories (It worked fine).
> One interesting question I can ask directly is if anyone knows if there is
> another temp directory used for image processing aside from "typo3temp". I
> am thinking either GD or ImageMagick is performing two functions here. One
> is a function to trim down the font (this is based on something I read)
> which would need a temp directory, then another to spit out the finished
> image (which I know goes into typo3temp. I ask because I had to fix the
> permissions on typo3temp to get it working where I have it now.
> If anyone has any ideas they can throw my way that would be very welcome.

Just a guess, as I can't tell if you've tried this or not from your
post: make sure that ImageMagick is where TYPO3 thinks it is. You can
run image processing tests from inside the TYPO3 install tool, and one
of the things it reports is whether or not the software can find IM.

Christopher Torgalson

More information about the TYPO3-english mailing list