[TYPO3-UG Italy] problema con aggiornamento fluid 6.0.1 -> 6.0.2

Alessandro Tuveri at at uniud.it
Tue Feb 11 14:17:26 CET 2014


Spiego un pochino meglio con il "beneficio d'inventario"
insomma (non so come) mi sono trovato con  il codice HTML e relativi stili, modificati dentro l'estensione speciality, NON piu' funzionanti una volta importanti in una installazione -- non posso escludere di aver tentato anche di installare le +ext dal repository sul sito esistente standard (TYPO3 CMS 6.1.7).
Non faccio uso di droghe quindi ad un certo punto ho verificato il codice che NON viene generato da speciality, ovvero: la generazione degli elementi di contenuto avviene  tramite il codice che vediamo in 1Column.html, 2.Columns.html, ecc.

Ho dovuto sostituire quindi span* con col-md* e row-fuild con row in tutti i markup e nei fogli di stile CSS.

Ho verificato che nello speciality nuovo c'e' anche all'interno una nuova cartella in:
Resources/Public/.... dove c'e' Styles ho trovato StyleSheets con gli stili per twbootstrap 3.0.

e anche i riferimenti in:
SharedResources.html

sempre in speciality. Vedro' meglio pomeriggio poi ti faro' sapere

salutoni

ALEX

________________________________________
Da: typo3-ug-italy-bounces at lists.typo3.org <typo3-ug-italy-bounces at lists.typo3.org> per conto di Marco Antonioli <antonioli at gammsystem.com>
Inviato: martedì 11 febbraio 2014 12:07
A: TYPO3 Usergroup Italy
Oggetto: Re: [TYPO3-UG Italy] problema con aggiornamento fluid 6.0.1 -> 6.0.2

Ciao

c'è poco da fare, ma il problema non lo vedo di TYPO3 ma di TwitterBootstrap e qui vedi lo stravolgimento:

http://getbootstrap.com/migration/

Da quanto capisco la nuova installazione di Fedext basata su TwitterBootstrap è relativa alla versione 3??
E quali sono le ext che lavorano con TB3?

grazie ciao

Marco Antonioli
Gamm System Srl

Tel +39 0372 25137
Fax +39 0372 557854
http://www.gammsystem.com
antonioli (at) gammsystem.com

P.IVA / CF 01066780196
REA CR - 132115
Tribunale di CR n. 9413
Capitale sociale € 22.879,48 i.v.

----- Messaggio originale -----

> Da: "Alessandro Tuveri" <at at uniud.it>
> A: "TYPO3 Usergroup Italy" <typo3-ug-italy at lists.typo3.org>
> Inviato: Martedì, 11 febbraio 2014 11:44:58
> Oggetto: Re: [TYPO3-UG Italy] problema con aggiornamento fluid 6.0.1 -> 6.0.2

> Pardon e grazie
> si mi riferisco a Flux
> fra le tante sebbene tutto quanto proposto sia molto interessante, purtroppo
> ci sono questi piccoli e seccanti problemi.
> Ho risolto per il be non funzionante tornando indietro alla v. 6.0.1.

> Inoltre ho avuto un altro seccante problema che mi ha fatto perdere delle
> ore, anticpo la cosa qui con l'impegno di documentare con un altro post.

> Circa il repository mi sembra che rispetto alla versione 6.1.7 di
> introduzione a tw bootstrap i moduli a disposizione, quindi differenti,
> siano
> flux: fluid flexform 6.0.2 (tw monta 6.0.1)
> vhs: fluid viewhelpers 1.8.4 (tw monta 1.8.2)

> Devo indagare meglio ma... mi sono trovato in questa situazione:

> * aggiornato un sito dalla v.4.5.32 alla 6.1.7 rimontando automaketemplate,
> ecc.
> * verificato che tutto e' ok ho tentato il passaggio alla versione tw
> bootstrap installando le estensioni di cui al sito fedex.net
> * alla fine ho deciso per una versione di twitter bootstrap 6.1.7 (intro)
> sulla quale montare il database

> devo capire ancora dove sta il problema, ma.... tentando l'uso di codice HTML
> relativo alla versione 1.1.0 speciality i contenuti non erano piu'
> disponibili nelle varie colonne; dopo varie ricerche ho scoperto che gli
> stili sono cambiati in pratica l'output passa, per le colonne, da classe
> span1... span12 a col-md-1 .... col-md-12 causa compatiblita' con bootstrap
> di twitter 3.0.

> questo e' veramente seccante. In pratica abbiamo online il package con la
> versione 2 ed alcune estensioni che lavorano con la versione twitter 3.0.

> In breve: la questione e' seccante perche' riutilizzando il codice per un
> nuovo sito questo non funziona; mi sono giocato un po' di tempo a rimettere
> il codice a posto e cambiare gli stili.

> qualcuno ha affrontato simili problemi?

> saluti

> ________________________________________
> Da: typo3-ug-italy-bounces at lists.typo3.org
> <typo3-ug-italy-bounces at lists.typo3.org> per conto di Marco Antonioli
> <antonioli at gammsystem.com>
> Inviato: martedì 11 febbraio 2014 11:06
> A: TYPO3 Usergroup Italy
> Oggetto: Re: [TYPO3-UG Italy] problema con aggiornamento fluid 6.0.1 -> 6.0.2

> Ciao

> forse ti riferisci a FLUX.
> Ho sperimentato anch'io il problema (e non ho una soluzione attualmente).
> L'unica cosa che ho visto è che su Fedext la versione che viene data stable
> è la 6.0.1 benchè nel ter sia resa disponibile la 6.0.2. Non vorrei che la
> 6.0.2 fosse una prerelease della versione che funzionerà con la 6.2 LTS ...
> ma non ho trovato informazioni a riguardo.
> Non ho provato e lo farò in settimana appena ho tempo, ma secondo me conviene
> aggiornare la ext da git e non da ter... quella che viene giù è sicuramente
> quella rilasciata in quel momento. Sul ter ci sono difficoltà a mio parere
> con le versioni in quanto non si può distinguere la compatibilità.
> Volevo provare la 6.0.2 perchè ho letto di questa nuova feature che permette
> di avere un collegamento al fal e una presentazione della img nel flexform
> tipo la img attuale della versione 6.1 (pensando fosse in questa release ma
> non ho certezze... )
> <flux:flexform.field.inline.fal name="myimage" multiple="TRUE" maxItems="5"
> enabledControls="{info:TRUE,new:TRUE,dragdrop:TRUE,sort:TRUE,hide:TRUE}"/>

> PS OFF TOPIC: anche aggiornando MEDIA (se la usi) ho avuto problemi con le
> form di backend fatte con i flexform di flux in quanto non riesco a
> selezionare i files. Di fatto non c'è la vecchia interfaccia ad albero nella
> scelta delle img ma solo la nuova interfaccia con tutte le img indistinte e
> cliccando sul più per aggiungere nulla succede.

> Marco Antonioli
> Gamm System Srl

> Tel +39 0372 25137
> Fax +39 0372 557854
> http://www.gammsystem.com
> antonioli (at) gammsystem.com

> P.IVA / CF 01066780196
> REA CR - 132115
> Tribunale di CR n. 9413
> Capitale sociale € 22.879,48 i.v.

> ----- Messaggio originale -----

> > Da: "Alessandro Tuveri" <at at uniud.it>
> > A: "TYPO3 Usergroup Italy" <typo3-ug-italy at lists.typo3.org>
> > Inviato: Martedì, 11 febbraio 2014 10:46:57
> > Oggetto: [TYPO3-UG Italy] problema con aggiornamento fluid 6.0.1 -> 6.0.2

> > Salve

> > nell'aggiornare fluid 6.0.1 verso 6.0.2

> > vedo il backend corrotto, in pratica tentando di modificare la pagina i
> > contenuti non vengono visualizzati; in luogo appare una margherita per una
> > frazione di secondo.

> > L'error log presenta questo errore:

> > [Tue Feb 11 10:37:46 2014] [error] [client xxx.xxx.xxx.xxx] PHP Fatal
> > error:
> > Call to undefined method
> > Tx_Fluidpages_Provider_PageConfigurationProvider::getGrid() in
> > /var/www/clients/client1/web1/web/typo3conf/ext/fluidpages/Classes/Backend/BackendLayout.php
> > on line 97, referer: http://t3615.uniud.it/typo3/backend.php

> > ? qualcuno ha idea di cosa possa essere o trattarsi ?

> > thanx

> > ALEX

> > _______________________________________________
> > TYPO3-UG-Italy mailing list
> > TYPO3-UG-Italy at lists.typo3.org
> > http://lists.typo3.org/cgi-bin/mailman/listinfo/typo3-ug-italy
> _______________________________________________
> TYPO3-UG-Italy mailing list
> TYPO3-UG-Italy at lists.typo3.org
> http://lists.typo3.org/cgi-bin/mailman/listinfo/typo3-ug-italy
> _______________________________________________
> TYPO3-UG-Italy mailing list
> TYPO3-UG-Italy at lists.typo3.org
> http://lists.typo3.org/cgi-bin/mailman/listinfo/typo3-ug-italy
_______________________________________________
TYPO3-UG-Italy mailing list
TYPO3-UG-Italy at lists.typo3.org
http://lists.typo3.org/cgi-bin/mailman/listinfo/typo3-ug-italy


More information about the TYPO3-UG-Italy mailing list