[TYPO3-typo3org] Upload with EM1 to TER2: SOAP fault (VersionMismatch: Wrong Version)

Ernesto Baschny [cron IT] ernst at cron-it.de
Thu Mar 2 15:45:44 CET 2006

Robert Lemke schrieb am 25.02.2006 23:45:

> the last few hours I've been debugging the EM1 upload to the TER2 SOAP
> server. Currently, when you try to upload an extension, the server (I
> think) throws the following exception:
>         VersionMismatch: Wrong Version
> Now, the weird thing is that if I upload an extension from my local server
> (with EM1) to my local installation of TYPO3.org it works! The main
> difference between the installations is that I run PHP 5.0.5-2ubuntu1.1 and
> at our live servers we run a php 5.1.2 on FreeBSD.

Couldn't you test your local Server with 5.1.2 to see if this is a
PHP-problem or some other "weirdness"?

> When I upload an extension from EM2 on my local server to the SOAP server at 
> the live TYPO3.org installtion, it works!

I've experienced the same problem here. Upload from 3.8.1 to typo3.org
doesn't work (same error as above), upload from 4.0-CVS to typo3.org works.

> Background information about the upload from EM1: The old extension manager
> sends its request via POST to typo3.org (ter.typo3.com to be exact) and
> there it is converted into a SOAP call (in the extension "extrep") which
> accesses the TER2 SOAP server. The SOAP client code (building of
> parameters, soap call) in extrep is exactly the same like the SOAP client
> code in EM2.

I don't know if I am looking at the right codes and I have not much SOAP
experience, but it looks to me that the "regular" client
(TYPO3core.CVS:mod/tools/em/class.em_terconnection.php:uploadToTER()) is
not doing any exception handling, while the "ter-gateway-client"
(CVS:tx_extrep/pi/class.tx_extrep.php:handleUpload()) is handling the

So maybe you just need to "ignore" that exception in extrep and keep on


More information about the TYPO3-team-typo3org mailing list