[TYPO3-ect] div: discuss browserSession
Franz Holzinger
franz at fholzinger.com
Mon Jun 16 09:59:02 CEST 2008
Hello,
there is a function browserSession in div:
function browserSession($key, $value = NULL) {
if($value != NULL)
$GLOBALS['TSFE']->fe_user->setKey('ses', $key, $value);
return $GLOBALS['TSFE']->fe_user->getKey('ses', $key);
}
Do you consider this as a good style to use a function for setting as
well as getting a value?
IMHO this is rather hard to follow. I would prefer to have setter and
getter functions for all kind of things.
function setBrowserSession
function getBrowserSession
- Franz
More information about the TYPO3-team-extension-coordination
mailing list