[TYPO3-core] How to get started with FAL from incubator....

Tolleiv Nietsch info at tolleiv.de
Thu Feb 16 23:53:04 CET 2012


Hi - the thumbnail thing is most likely related to 
http://forge.typo3.org/issues/33958 (the .htaccess protection of 
fileadmin/_temp_)

Cheers,
Tolleiv


Susanne Moog schrieb:
> On 16.02.2012 19:18, Susanne Moog wrote:
>> hey,
>>
>> On 14.02.2012 22:25, Benjamin Mack wrote:
>>> I do this:
>>>
>>>   * a normal 4.6.4 blank package installation
>>>   * Cloned git://git.typo3.org/TYPO3v4/Incubator.git
>>>   * checked out the remotes/origin/plain-fileabstraction branch into a
>>> local one
>>>   * changed t3lib typo3 and index.php to come from the new sources
>>>   * installed EXT:file (not sure if all of them are needed?), soon
>>> EXT:file will not be needed at all anymore
>>>   * Do a Compare Database / Update Tables in the install tool
>>>   * Create a File Storage on PID=0 through the list module (set it to
>>> fileadmin/ if you'd like)
>>>   * Clear caches etc
>>
>> I am also trying to get it to work and have some problems:
>>
>> I got no thumbnails in my converted image elements and whenever I try to
>> add another file I get a fatal error:
>>
>> Fatal error: Call to a member function getPublicUrlForFile() on a
>> non-object in /var/www/fal/t3lib/file/AbstractFile.php on line 466
>>
>
> I don't know why but if I add
>
> $this->storage = $this->originalFile->getStorage();
>
> to the __construct of class t3lib_file_ProcessedFile it starts working
> (somehow, still no thumbnails, but no error either...).
>
>
>

-- 
twitter.com/tolleiv
blog.tolleiv.de - www.aoemedia.de



More information about the TYPO3-team-core mailing list