[TYPO3-core] Gerrit and Mr. Jenkins

Steffen Gebert steffen.gebert at typo3.org
Thu May 12 09:30:57 CEST 2011

Hi Markus,

> Patch Set History:
> Set 1: Initial set
> Set 2: Corrected commit message
> Set 3: Accidentally pushed for branch 4-5 with same ChangeId.
> Set 4: Pushed again for master.
> à Result is an error from Mr. Jenkins
> I can’t push another amended commit, since gerrit says: No changes

Umm.. as explained here [1] (and this is what you probably tried) is 
that you have to amend the commit. It worked for me, when I did the same 
as you did.

* check out patch set 2
* git commit --amend
* git push origin HEAD:refs/for/master

After amending, the commit should have a new SHA (because of the changed 
commit time stamp).

Could you post the Gerrit ID? I could give it a try.

Kind regards

[1] http://wiki.typo3.org/TroubleShooting_(Git)#Pushing_old_Patch_Set_again

Steffen Gebert
TYPO3 v4 Core Team Member

TYPO3 .... inspiring people to share!
Get involved: http://typo3.org

More information about the TYPO3-team-core mailing list