[TYPO3-core] RFC: #6829 - New general template-class usable for FE+BE

Dmitry Dulepov [typo3] dmitry at typo3.org
Mon Nov 26 10:06:59 CET 2007


Hi!

Steffen Kamper wrote:
> so same for parameters?
> function($a, $b = 'green') {

Yes. There are still functions that have "$a=1" but these are old functions. extdeveval reformats tham to "$a = 1".

I actually would vote for using realbolean parameters when we need boolean in the function. Currently most often it looks like:

function a($booleanParam = '') {
	...
}

but should be

function a($booleanParam = false) {
	...
}

And if function wants to return false, there must be a "return" statement, not silent exist without no return. This really enhances readability of the code and simplifies bug hunting.

-- 
Dmitry Dulepov
TYPO3 core team
Web: http://typo3bloke.net/
Skype: callto:liels_bugs


More information about the TYPO3-team-core mailing list