[TYPO3-core] RFC: Feature Request 5424: Menu cache expire time should be configurable

Oliver Hader oh at inpublica.de
Mon Apr 23 18:30:09 CEST 2007

Oliver Hader wrote:
> Martin Kutschker wrote:
>> Ok, but... get_cache_timeout() has no return statement.
> Of course, I'll fix this.
>> And please make it getCacheTimout() - or should it be getCachePeriod? -
>> to follow the naming convention of tslib_fe and tslib_menu.
> There was already a function tslib_fe::set_cache_timeout_default(...)
> and I kept this also for the function get_cache_timeout(). But no
> problem with changing it to getCacheTimeout().
>> PS: Why is it page.cache_timeout but config.cache_period?
> "cache_timeout" is the fieldname of table pages. "cache_period" is a
> TypoScript property. I don't know why this is different.
> If there are no more comments/requests to the patch, I'll send the fixed
> version (including the return value) today.

Here is the new patch - fixing the return statement only.

Oliver Hader
-------------- next part --------------
A non-text attachment was scrubbed...
Name: 0005424_v2.patch
Type: text/x-patch
Size: 2718 bytes
Desc: not available
Url : http://lists.netfielders.de/pipermail/typo3-team-core/attachments/20070423/63f24648/attachment.bin 

More information about the TYPO3-team-core mailing list