[TYPO3-mvc] access to ChildNodes arguments
Bastian Waidelich
bastian at typo3.org
Fri Jul 31 11:56:47 CEST 2009
Christian Zenker wrote:
Hi Christian,
>> I'd iterate through the children and execute their render method. [...]
> This is a good idea.
> But it might become a problem, if the children of a CaseViewHelper
> return an empty string on purpose.
They can return NULL or FALSE as well.
>> BTW: I'd rename the "label"-attribute to "condition" or something alike.
>
> I didn't use "condition" as it might be mixed up with the IfViewHelper's
> "condition".
Well, it could be "value" or "caseCondition" or "if". But "label" seems
to be wrong to me ;)
Bastian
More information about the TYPO3-project-typo3v4mvc
mailing list