[TYPO3-shop] Payment GW: 'This' Must be Object!

Juan Pablo Villaverde jpablo at omnisciens.com
Sat Jan 12 20:26:06 CET 2008


Solved! I was using a the old style object call: $this, the correct way is 
to use $this->pibase
But now there is another problem, I just tried to use the payment_DIBS 
extension with this error message:

Warning: Missing argument 3 for init() in C:\Archivos de programa\Apache 
Group\Apache2\htdocs\testsite\typo3conf\ext\tt_products\view\class.tx_ttproducts_basket_view.php 
on line 78

Fatal error: Call to a member function on a non-object in C:\Archivos de 
programa\Apache 
Group\Apache2\htdocs\testsite\typo3conf\ext\tt_products\pi1\payment_DIBS.php 
on line 61

this is the handlescript call: handleScript = 
EXT:tt_products/pi1/payment_DIBS.php
The fatal error is in this call:  $orderUid = $this->order->getBlankUid();
and I really need the Order UID :-)

tt_products version 2.6.0

jp

"Juan Pablo Villaverde" <jpablo at omnisciens.com> escribió en el mensaje 
news:mailman.1.1200164457.30190.typo3-project-tt-products at lists.netfielders.de...
> In a payment extension for tt_products, like payment_DIBS,  I get this 
> message:
>
> $this and $this->cObj must be objects!
>
> when I call the payment handlescript. I tried with the original DIBS 
> handlescript with the same result.
> I need to specify something more than the handlescript to make the "THIS" 
> available from the payment class?
>
> The config is ver simple, something like:
>
> plugin.tt_products {
>
> tpvExt {
> }
> payment >
> payment {
>  10 {
>   title = TPV
>   handleScript = 
> EXT:user_tpv/class/class.usertpv_ttproducts_paymentTpv.php
>  }
> }
>
> }
>
> I just found via google a post of people with the same proble, but nobody 
> posted a reply: 
> http://lists.netfielders.de/pipermail/typo3-ug-spain/2004-October/000401.html
>
> Thanks in advance!
>
> jp
> 




More information about the TYPO3-project-tt-products mailing list