[TYPO3-templavoila] InvalidArgumentException: Argument was supposed to be either a uid or a filename

Kees-Jan Koster keesjan at koster.cx
Fri Aug 13 16:18:44 CEST 2010

Hi Tolleiv,

Thanks for your reply. I updated Templavoila to latest trunk, after that the
InvalidArgumentException dissapeared but now I get an Templavoilia Error
stating that no DS/TO is selected for the current page. I tried clearing the
cache and after that I can view a page in the FE, only the first page I view
after clearing cache, all other pages state the TV Error in a yellow box.

I tried removing the TV Framework and removing all TO's and after
reinstalling it didn't solve the issue. I still got the TV error.

After that I installed the version from TER (1.4.2) and everything works
correct again. I still don't know what triggered the error in the first
place, because everything worked for more than a week with the trunk
version. I couldn't find any FCEs without proper DS/TO.

For now this will work for me, I hope this can be solved in the next
version. Please let me know if I can help with any other information about
my installation that can help you solve this.

By the way, with the latest trunk version I saw an style error in the Page
module for the tabs "Non-Used Elements" and "Advanced Functions", their
content was hidden behind the rest of the page, I used IE8.

Thanks again,

More information about the TYPO3-project-templavoila mailing list