[Neos] installing/deploying neos offline / without composer

Karsten Dambekalns karsten at typo3.org
Fri Apr 10 08:54:57 CEST 2015


Hi.

> On 09.04.2015, at 23:11, Michal Z <michal.zitko at hp.com> wrote:
> 
> possibly my PHP version is too low oO
> [Thu Apr 09 23:06:39 2015] [error] [client 10.213.40.207] PHP Fatal error:  Call to undefined method DirectoryIterator::getExtension() in /var/www/neos/Data/Temporary/Development/Cache/Code/Flow_Object_Classes/TYPO3_TypoScript_Core_Parser.php on line 557, referer: http://vwskbaubav16/neos/login
> 
> (/var/log/httpd)(root)#php --version
> PHP 5.3.3 (cli) (built: Oct 23 2014 06:58:46)

Hm, wanted Neos 1.2.3, right? That should be compatible with PHP 5.3… But indeed with https://review.typo3.org/33809 we introduced the use of getExtension() which is available only as of PHP 5.3.6. Sorry for that…

Then again, 5.3.3 (your version) has been released on July 22nd 2010. The latest PHP 5.3 version was 5.3.29, released Aug 14th 2014. And PHP 5.3 is no longer supported. So, if you have any chance of upgrading our PHP version, please do, you can only benefit from that (security, speed, less bugs, …)

Regards,
Karsten Dambekalns
--
karsten at typo3.org

Inspiring People to Share







More information about the Neos mailing list