[Neos] Exception #1391806394: Image resource file could not be found

Michael Schams typo3.lists at 2015.trash.schams.net
Wed Apr 8 14:49:37 CEST 2015

Hi Jean!

Thanks for taking the time and explaining your installation steps in

In fact, it's not the first time that I install Neos and it worked
without problems in the past (and definitely with the same steps in
older versions... reproducible). There must be a change in recent
versions that causes this issue I suspect.

However, I have to admit, that my setup is a little bit unusual:
installing Neos, flushing the cache, deleting directories, cloning the
server, booting the clone, creating a new admin user via command line,
etc. and everything as automated as possible :-)

Your explanations might be useful indeed (definitely not wasted time,
mate!) and I appreciate your feedback.

I will compare my steps with your suggestions and check if I can find
anything that causes exception #1391806394.

Thanks again.

On Mon, 2015-04-06 at 00:45 +0200, Jean Claude wrote:
> hello Michael
> I am not an expert, I am a beginner !..
> I had many problems with the installation on a local computer with windows 7, but after a very long time, I found a solution that works.
> Then I took an on line server with Plesk and Ubuntu ...
> it is best to start installation with "Composer" . 
> after loading, you must create the folder _Resources
>  in  Neos/Web /_Resources ..
> then, to prepare the Data folders, I select : (Development  or Production )
> FLOW_CONTEXT=Development ./flow flow:cache:flush FLOW_CONTEXT=Production ./flow flow:cache:warmup
> then, I followed the advice by granting rights with the command line:
> /flow core:setfilepermissions <commandlineuser> <webuser> <webgroup>
> but with Plesk and Ubuntu, 
> the permissions are not installed correctly ...
> because "setfilepermissions" told me "psaserv" and "psacln" does not exist 
> but, they do exist ... perhaps I badly configured my server  ?
> I have to do a chmod 777 on all folders
> Neos / Data files, Neos / Package etc ...
> and then to do
> chown -R owner:psacln /var/www/vhosts/your_domaine.com/httpdocs/Neos
> (for me owner = jccosse)
> to properly put the owner and the group (psacln) to all folders and files.
> I sometimes have to do it again after  "  ./flow flow:cache:flush --force  "
> and I run the project creation ....   http://your_domaine.com/setup
> and each time, everything works fine...
> I think if your project Neos working properly, if you completely delete the "Data" folder and then
> create folders with (Development  or Production )
> FLOW_CONTEXT=Development ./flow flow:cache:flush FLOW_CONTEXT=Production ./flow flow:cache:warmup
> /flow core:setfilepermissions <commandlineuser> <webuser> <webgroup>
> and I run again  the project creation ....   http://your_domaine.com/setup
> selecting your database without creating a new user and clicking "skip" before the creation of the project, you will arrive directly on the choice of "Frontend" or "Backend" and you find your project as it was before ...
> I don't  know if it will help you understand,
> but I chose to write to make perhaps a response to those who have problems with Plesk and Ubuntu :)
> best Regards
> jean-claude
>  ..... I worry about saving a project because I discover problems that I can not find a solution ! ....
> _______________________________________________
> Neos mailing list
> Neos at lists.typo3.org
> http://lists.typo3.org/cgi-bin/mailman/listinfo/neos

More information about the Neos mailing list