[Neos] TYPO3 Neos 1.1.2 | Out of memory

Michael 9pm at gmx.net
Fri Nov 7 14:07:56 CET 2014


i've installed TYPO3 Neos 1.1.2 on a 1und1 Server. During installation i've had several problems with a fatal error "out of memory". When i've called "myDomain.de/setup/" i got one of these errors. But fortunately i have access via SSH and i can run [flow:core:compile] via command line. Then i could enter the password and got to the first step (database). After inserting the database information i got the next memory error and i've executed [flow:doctrine:migrate]. That was the last memory error during installation and i successfully finished it. But when i now entering the frontend i get the next error. This is the whole message:

Fatal error: Out of memory (allocated 39321600) (tried to allocate 7168 bytes) in /homepages/xxxx/xxxxxxx/htdocs/Data/Temporary/Development/Cache/Code/Flow_Object_Classes/TYPO3_Fluid_Core_Compiler_TemplateCompiler.php on line 357

I already executed [./flow flow:cache:flush --force] and [./flow flow:core:compile] on the command line. But i still get this error. I've searched Google for hours and i only find problems with the PHP memory_limit. But in my php.ini i set memory_limit to "2048M" (i've tried several other limits too). I use PHP 5.5.18 and when i call phpinfo() it shows me the exact same memory_limit i've set in the php.ini.

Does anybody know where the problem could be?

Kind regards

More information about the Neos mailing list