[TYPO3-50-general] Flow3 on OS X 10.5.6 with Macports

Martin Klepsch martinklepsch at googlemail.com
Sun Feb 22 17:14:04 CET 2009


Hi,i tried the same thing like sebastian. following the same tutorial.

i have a working php5-devel macports installation, installed like karsten
posted in the comments of the tutorial.
( port install php5-devel +apache2+macosx+mysql5+pear+postgresql83+sqlite )

i checked out the newest revision from this url:
https://svn.typo3.org/TYPO3v5/Distribution/trunk/ like recommended by
sebastian kurfürst in another mailinglist post.

then i ran the fixpermissions: sudo sh fixpermissions.sh _www staff

if i open up my vhost at f3.dev i get an error:
#1219326502: Could not connect to DSN
"sqlite:/Users/martin/Sites/devroot/gimme5/Data/Persistent/TYPO3CR.db". PDO
error: could not find driver
which links to this wiki page: http://wiki.typo3.org/Exception1219326502

so i looked into my php.ini, but there is everything right:
extension=php_pdo.dll
;[...everything between is disabled]
extension=php_pdo_sqlite.dll

so does anybody know whats wrong?

sorry for my bad english.
cheers,
martin


On Wed, Feb 4, 2009 at 10:59 AM, Karsten Dambekalns <karsten at typo3.org>wrote:

> Hi.
>
> On 04.02.2009 1:03 Uhr, Sebastian Wojtowicz wrote:
> > Now I wanted to update, but I'm stuck again, I don't know how to teach
> > my server to use the beta1 files.
> >
> > It keeps beeing 5.3alpha3. But I have to add, that I also don't know
> > which other commands I could use beside those in the tutorial. So I
> > guess that would be a reason.
>
> This should do it:
>
> sudo port -v selfupdate
> sudo port upgrade php5-devel
>
> sudo /opt/local/etc/LaunchDaemons/org.macports.apache2/apache2.wrapper
> restart
>
> Regards,
> Karsten
> _______________________________________________
> TYPO3-project-5_0-general mailing list
> TYPO3-project-5_0-general at lists.netfielders.de
>
> http://lists.netfielders.de/cgi-bin/mailman/listinfo/typo3-project-5_0-general
>


More information about the TYPO3-project-5_0-general mailing list